mikrotik

Ответить
brahman
Site Admin
Сообщения: 49
Зарегистрирован: 30 май 2020, 13:42

mikrotik

Сообщение brahman »

Итак, что такое Hairpin NAT и зачем он нужен.
Данная конфигурация обычно требуется, если Вы опубликовали на внешнем адресе (dst-nat) локальный сервер, и Вам необходимо чтобы он был доступен по внешнему адресу изнутри сети.

Начнем с базовой конфигурации сети.

Вы имеете IP адрес 1.1.1.1/24 на интерфейсе WAN вашего маршрутизатора
Вы имеете IP адрес 192.168.0.1/24 на интерфейсе LAN вашего маршрутизатора.
Вы имеете www-сервер с адресом 192.168.0.10 в LAN сегменте.
Адрес вашего компьютера находится в диапазоне адресов LAN. Для примера пусть это будет 192.168.0.5

Код: Выделить всё

/ip firewall nat

add action=dst-nat chain=dstnat dst-address=1.1.1.1 dst-port=80 protocol=tcp to-addresses=192.168.0.10

add action=masquerade chain=srcnat dst-address=192.168.0.10 dst-port=80 protocol=tcp src-address=192.168.0.0/24


Ответить